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1  Úvod 
 

Väčšina začínajúcich tvorcov prišla na spôsob ako vytvoriť si napr. dres, ľad alebo 
hocičo iné. Problémom však už pre viacerých je proces importovania add-onu do hry, 
ktorý im robí problémy. Týmto návodom na importovanie sa Vám pokúsim túto 
problematiku ujasniť.  

1.1 Čo na to potrebujeme? 
Na importovanie potrebujeme: 

• FshX (http://www.s-games.eu/storage/addony/FshX.rar) 
• BigGUI (http://www.s-games.eu/storage/addony/BigGUI.rar) 
• Notepad (Poznámkový blok) 
• Import Tools v hl. priečinku hry (http://s-

games.eu/Addony/NHL%2008_09%20Import%20Tools.rar) 
• NHL View – iba v niektorých prípadoch 

(http://www.cznhl.com/download_manager.php?id=525151023aa) 

To je asi tak všetko, čo by sme mali potrebovať. 

1.2 Štruktúra súborov 
Dobré by bolo vlastne ešte spomenúť, že tu popisujeme grafické add-ony (teda 

všetko okrem zostáv, ktoré sa svojou tvorbou a aj inštaláciou úplne vymykajú 
z normálu). Na začiatok by bolo dobré povedať, že v akých súboroch sú uložené tie 
textúry (teda ten obrázok, čo ste si vo Photoshope vytvorili). Textúry sú vždy uložené vo 
fsh súboroch. Fsh súbory sú zas uložené buď priamo vo viv súboroch alebo ešte 
medzitým v big súboroch a až tie sú následne uložené vo viv súboroch alebo sú uložené 
len vo v big súboroch. 

Opísať slovami je to ťažké. Vôbec by som sa nečudoval, keby ste tomu 
neporozumeli, tak tu prikladám to aj graficky znázornene: 

 

1.3 Na čo slúžia programy? 
V stati 1.1 sme si vypísali zoznam programov, ktoré budeme potrebovať na 

importovanie. Teraz si povieme na akú činnosť ich potrebujeme. 

• FshX 
- Importovanie textúr do *.fsh súborov 
- Otváranie *.fsh súborov 

• BigGUI 
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- Otváranie *.big a *.viv súborov 
- Importovanie ľubovoľných súborov do *.big a *.viv súbora 

• NHL View 
- Úprava zostáv (ale to nás teraz nezaujíma) 
- Zisťovanie tzv. „artov“ 

• Notepad 
- Písanie príkazov do *.bat súboru, ktorý je inštalátorom 

• Import tools 
- Dôležité na správne fungovanie *.bat súboru a hladký priebeh inštalácie 

2 Fsh a big súbory 

2.1 Hľadanie fsh súboru 
Samotný fsh súbor vytvoriť nedokážeme. Teda dokážeme, ale na to sú iné 

programy, ktoré nás teraz nezaujímajú. Našou úlohou nie je vytvoriť fsh súbor, ale 
upraviť už existujúci. Na to, aby sme ho upravili, tak ho musíme mať. Toto je asi tá 
najzložitejšia časť. Najjednoduchší spôsob je asi ten, že si stiahneme nejaký add-on, 
ktorý je rovnaký ako ten, ktorý chceme vytvoriť my (nie úplne totožný, ale musí byť 
rovnaký „štruktúrne“. Teda ak my chceme spraviť dres, tak to nebudeme robiť na fsh 
súbore pre ľad, ale pre dres). Toto je však dobrý spôsob ako si skrátiť čas, ale v podstate 
k ničomu nevedie a stále nebudeme vedieť princíp vytvorenia batky (*.bat súbor – 
inštalátor). Preto skôr odporúčam druhý spôsob. Hlavne, ak začínate, aby ste si nebrali 
„cudzie“ fsh. 

Tento je o dosť zložitejší, ale naučíte sa pri ňom hľadať a tvorba batky bude pre 
Vás jednoduchšia na pochopenie. 

Princíp je jednoduchý. Otvoríme *.big alebo *.viv súbor a budeme hľadať ten 
súbor, ktorý potrebujeme na svoja add-on. Aby ste to mali jednoduchšie tak hneď sem 
píšem pár „destinácií“. 

• Dresy -> gamedata\jerseys.viv (súbory uniYYY_XX.fsh pre dres a helmy, 
numYYY_XX.fsh pre čísla a letters_YYY_XX.fsh pre písmená, kde YYY je art 
tímu a XX číslo dresu) 

• Ľady -> gamedata\IceTxtrs.big (súbory ICE_YYY.fsh, kde YYY je art tímu) 
• Tváre -> gamedata\faces.viv a následne big súbor FACEYYYY.big, kde YYYY je 

art hráča a vo vnútri big súboru je súbor *.fsh 
• Brankári -> gamedata\faces.viv (ELITE formát) (súbory 

goalies_helm_YYYY.fsh pre masku, goalies_pads_YYYY.fsh pre výstroj 
a goalies_stick_YYYY.fsh pre hokejku, kde YYYY je art hráča); 
gamedata\goalies.viv (klasický formát, viď. tváre) 

• Dresy do menu -> fe\jerapt.viv a následne big súbor JERS_AAA_XX.big, kde 
AAA je skratka tímu a XX číslo dresu, kde je aj fsh súbor 

• Logá -> fe\tlogapt.viv a následne big súbor (súbory LOGO_AAA_MED/LRG, 
kde AAA je skratka tímu a MED alebo LRG veľkosť loga) so skratkou tímu, kde 
je aj fsh súbor 

• Fotky -> fe\portapt.viv a následne big súbor s artom hráča 
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To sú asi tie základné. Na ostatné prídete postupom času pri hľadaní alebo 
zisťovaní v batkách. Spomenul som tu nejaké nové slovíčko – art. Čo je to ten art? Art je 
špecifické číslo hráča alebo tímu. Funguje preto, aby sa nestalo, že v celej hre bude 
jeden ľad alebo jeden dres. Ako som to naznačil, ten art je v názve súboru. Teda napr. 
dres pre Atlantu Thrashers má art uni001_X.fsh. Hrubo vyznačený je art. Art zistíme 
vďaka NHL View, kde si otvoríme zostavy (súbory db.viv v hlavnom adresári hry 
a priečinku db a exhibition.exh v mojich dokumentoch a priečinku NHL09), prepneme na 
Teams a vyberieme art (nie Team ID!). 

 To isté aj pri hráčoch. Nejaký hráč má tvár FACE156.big. Číslo 156 sme zistili 
vďaka NHL View, kde 156 bolo v kolónke Photo/Cyberface (nie Player ID!). 

Vráťme sa k dresom. Zostala tam jedna „premenná“ (hádam sa na mňa nikto 
nenahnevá, keď to tak nazvem). Vyššie som písal, že je to číslo dresu. Teda, že či je to 
dres na domáce zápasy, či na zápasy vonku atď. Pravidlá sú takéto: 

• 0 – dres na zápasy vonku 
• 1 – dres na zápasy doma 
• 2 – tretí dres 
• 3 – štvrtý dres 
• … 
• 14 – pätnásty dres (posledný možný) 

Rovnaké je to aj u dresoch do menu. Len s tou výnimkou, že tam sa vždy udávaj 
dvojčíselný formát, teda nenapíšeme JERS_ATL_0.big, ale JERS_ATL_00.big. Týchto 
rozdielov medzi formátmi je viac: 

• Dresy – uni001_0.fsh; uni1_00.fsh; uni1_0.fsh 
• Ľady – ICE_001.fsh; ICE_1.fsh 
• Tváre/brankári – FACE150.big; FACE0150.big 
• Dresy do menu – JERS_ATL_00.big; JERS_ATL_0.big 

Postupom času si snáď na tieto paradoxy zvyknete. Aspoň dúfam. Po otvorení 
jednotlivých big alebo viv súborov označíme v zozname ten fsh alebo big súbor ktorý 
potrebujeme a dáme Edit -> Export a vyberieme mu miesto na uloženie. Ak je to big 
súbor, tak ho otvoríme ešte raz prostredníctvom BigGUI, označíme si fsh súbor a znova 
dáme Edit -> Export a uložíme tam, kde to uznáme za vhodné. 

2.2 Import do *.fsh 
Vybratý súbor už hádam máme a teraz ideme k procesu importovania. Otvoríme 

FshX, dáme File -> Open a vyhľadáme fsh súbor. Ten . Mala by byť vo formáte *.bmp. 
Ale nemusí. Ako na to? Dáme hviezdičku do poľa pre názov a stlačíme enter a už 
môžeme vyhľadávať všetky ostatné súbory.  

Po vybraní textúry si súbor uložíme (File -> Save As) a dáme mu názov. Pri 
vytváraní názvu sa držíme „pravidiel“, o ktorých som hovoril v stati 2.1. 

2.3 Import do *.big 
Táto funkcia sa netýka všetkých add-onov, ale len tých pri ktorých je ešte 

potrebná úprava do big súboru, napr. dresy do menu, logá a pod. I keď, vlastne cez 
batku sa tiež dá spraviť import do big súborov, ale niekedy sa tým len zbytočne predlžuje 
čas inštalácie. BigGUI sa ovláda tiež jednoducho. Otvoríme ho dáme File -> Open 
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vyhľadáme *.big súbor, do ktorého budeme importovať fsh súbor (musíme ho mať ešte 
z času kedy sme hľadali fsh súbor). Dáme Edit -> Import a odsúhlasíme jeho 
prepísanie. Na záver ešte potrebujeme prestavať súbor. Znie to síce katastrofálne, ale je 
to jednoduché. File -> Rebuild a je to. 

3 Import do hry 

3.1 Ručné vkladanie 
Táto stať by sa mohla volať písanie bat súboru. Ale ja to tak nechcem, keďže je tu 

aj spôsob ručného importu do hry. Ten síce nevyužívam, ale rád by som Vám o ňom 
povedal, keďže aj takýto spôsob existuje. 

V zásade spravíme úplne to isté ako pri hľadaní fsh súboru. Vyberieme big alebo 
viv súbor, kde sú uložené fsh alebo big súbory tých add-onov, ktoré si tam chcete dať 
(t.j. pre dresy napr. jerseys.viv a pod., viď. stať 2.1). Ak máme ten big alebo viv súbor 
otvorený, dáme File -> Import a importujeme si vlastný big alebo fsh súbor, ktorý sme 
si vytvorili podľa pokynov v stati 2.2, resp. 2.3. Odsúhlasíme jeho prepísanie a teraz si ho 
nájdeme v tom súbore. Samozrejme, komu by sa chcelo hľadať niekedy medzi stovkami 
súborov. Preto si súbory zoradíme podľa „Packed (uncompressed)“ a vyznačíme tie, 
ktoré majú v tomto stĺpci No pričom však to musia byť súbory, ktoré sme my 
importovali! Po označení dáme Edit -> Compress a na záver znovu File -> Rebuild. 
Spustíme BHImport.bat a môžeme sa pokochať vlastným add-onom v hre.  

3.2 Vkladanie pomocou bat súboru 
Toto je najčastejší spôsob vkladania. Prečo? Keď sa vydáva add-on tak je určite 

lepšie ho vydať s inštalačným súborom.  

Na vytvorenie bat súboru nepotrebujeme nič iné ako len Notepad. Na vytvorenie 
funkčného bat súboru funguje akási „šablóna“: 

 ImpBIG /i adresa súboru do ktorého importujeme súbor súbor /c 

  ImpBIG /r adresa súboru do ktorého importujeme 

Teraz si to pekne poďme vysvetliť.  

• ImpBIG – volá súbor ImpBIG.exe, teda hovorí, že ImpBIG.exe spraví... 
• /i – ...spraví import, teda importuje 
• adresa súboru do ktorého importujeme – tu myslím, že netreba nič dodať. 

Hádam len to, že sa začína od hl. adresára hry – t.j. pre dresy zadáme tam 
gamedata\jerseys.viv. 

• súbor – súbor, ktorý importujeme – dávame ho dva razy za sebou, nie je 
to chyba! Prirodzene, zadávame jeho názov 

• /c – kompresovanie importovaného súboru 
• /r – prestavanie (rebuild) súboru, do ktorého importujeme 

Import dresu uni000_1.fsh by vyzeral teda takto: 

 ImpBIG /i gamedata\jerseys.viv uni000_1.fsh uni000_1.fsh /c 

  ImpBIG /r gamedata\jerseys.viv 
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Ak chceme importovať naraz písmená a čísla tak to nie je žiaden problém. Len 
skopírujeme prvý riadok a zmeníme názov. Zároveň ho prilepíme pred ten posledný! 
Teda vyzerať to bude takto: 

 ImpBIG /i gamedata\jerseys.viv uni000_1.fsh uni000_1.fsh /c 

 ImpBIG /i gamedata\jerseys.viv num000_1.fsh num000_1.fsh /c 

  ImpBIG /r gamedata\jerseys.viv 

Iné to bude, ak budeme chcieť nainštalovať dres, čísla a ľad pre jeden tím. Ľad sa 
nachádza už v inom súbore ako jerseys.viv, tak preto inštalačka bude vyzerať takto: 

 ImpBIG /i gamedata\jerseys.viv uni000_1.fsh uni000_1.fsh /c 

 ImpBIG /i gamedata\jerseys.viv num000_1.fsh num000_1.fsh /c 

  ImpBIG /r gamedata\ jerseys.viv 

 ImpBIG /i gamedata\IceTxtrs.big ICE_000.fsh ICE_000.fsh /c 

 ImpBIG /r gamedata\IceTxtrs.big 

Okrem tohto tu máme aj iné príkazy: 

• del *.fsh – Zmaže všetky *.fsh súbory, ktoré sú v adresári kde je *.bat 
súbor (dobré preto, aby sa nehromadili zbytočne už nainštalované add-
ony). Hviezdičku môžeme nahradiť názvom súboru alebo aj príponu 
môžeme zmeniť, čiže nakoniec to môže vyzerať aj takto: del hlava.doc 

• pause – vypíše hlášku: „Pre pokračovanie stlačte ľubovoľnú klávesu“ 

Tieto príkazy zväčša dávame na koniec súboru (del príkaz nikam inam, predsa 
nevymažeme súbory skôr ako s nimi spravíme operácie…). Príkaz pause sa dáva často 
pred BHImportom. Áno, pred BHImportom. Do batky totižto môžeme dať aj obsah 
BHimport-u tak, že prepíšeme jeho koncovku z *.bat na *.txt a skopírujeme jeho obsah 
na koniec batky. 

Na záver si ešte ukážeme (hlavne pre tých lenivých) ako spraviť batku, ktorá nám 
importuje fsh súbor do bigu a následne ešte do viv súboru. 

 ImpBIG /e fe\tlogoapt.viv LOGO_LRG_AUG.big LOGO_LRG_AUG.big 

 ImpBIG /i LOGO_LRG_AUG.big LOGO_LRG_AUG.fsh LOGO_LRG_AUG.fsh 

  ImpBIG /i fe\tlogoapt.viv LOGO_LRG_AUG.big LOGO_LRG_AUG.big /c 

 ImpBIG /r fe\tlogoapt.viv 

Prvý riadok nám hovorí, že zo súboru tlogoapt.viv, ktorý je umiestnený 
v priečinku fe exportuje súbor LOGO_LRG_AUG.big. Druhý riadok začína tým, že do 
súboru LOGO_LRG_AUG.big importujeme náš LOGO_LRG_AUG.fsh. Tretí riadok prikazuje 
importovať do súboru tlogoapt.viv nami upravený súbor LOGO_LRG_AUG.big, ktorý aj 
kompresneme a rebuildneme (štvrtý riadok). V podstate tu máme len jeden nový príkaz. 
A síce /e: 

• /e – exportuje zo súboru XY súbor WZ. 

Tak ak máme napísanú batku, tak môžeme v Notepade (v slovenskom Windowse 
Poznámkový blok) dať Súbor -> Uložiť ako. V kolónke názov máme *.txt. Príponu .txt 
zmeníme na .bat a pred .bat samozrejme dáme názov našej inštalačky. Uložíme 
a inštalujeme tak ako všetky ostatné add-ony. To je k inštalácii add-onov všetko, verím, 
že Vám tento návod aspoň trochu pomohol ☺. 


